
TestDrive Tutorial 
 

INTERGRAPH SmartPlant P&ID 

Intergraph SmartPlant P&ID is an asset-centric, rule-driven engineering solution that creates and 
maintains the plant configuration and related process, equipment, instrumentation, and piping data for the 
life of the plant. 

Read more about SmartPlant P&ID. 

In this test drive, you see the strengths of SmartPlant P&ID. 

Try any of the following workflows: 

  Streamline Engineering with Design Rules to discover how SmartPlant P&ID ensures 
design accuracy and consistency. 

 Edit a System the "Smart" Way Using SmartPlant P&ID to see how system editing 
capabilities allow fast and consistent data entry. 

  Bulk Data Editing with Engineering Data Editor to see how to significantly reduce the 
design update cycle time. 

  Create a Display Set to learn how display sets easily create deliverables to execute 
specific tasks. 

 Create a Report to generate reports in a familiar Microsoft Excel spreadsheet. 

  Compare Drawing Versions to see how to maintain multiple versions of P&IDs to make 
comparisons and roll back design to earlier versions. 

 

 

Edit a System the "Smart" Way Using SmartPlant P&ID 

Engineering data and data consistency are key in SmartPlant P&ID. SmartPlant P&ID allows you to 
modify the process systems on a P&ID to meet the specifications of your project. The software uses rules, 
either existing or customized by your company, to ensure your changes are: 

 Consistent with the design basis 

 Correct 

 Complete 

 Consistent across the design 

Try the example below and see for yourself. 

1. In the example P&ID, click a pipe run. 
2. In the Properties window, find Nominal diameter. It is currently set at 4”. Click the list and 

select 6”. 
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The entire pipe run section that is changed to 6" is highlighted. The software recognizes any section that 

should not be changed; for example, sections that are connected to a reducer. At the point that Nominal 

Diameter is selected in the property grid, the system editing scope is highlighted. 

  

 

3. For all nozzles and pipe runs set the Fluid code to P and the Piping materials 
class to 1C0031 in the Properties window. 

 

The entire pipe system remains highlighted because the fluid code does not impact the pipe 

line components. 

4. In the example P&ID, click an instrument in a loop. 
5. In the Properties window, set the Tag Seq No for the instrument to 12820. 
6. In the Properties window, set the Construction Status for the system to Existing. 

 

The entire piping system, including instruments and connections to process lines, is 

highlighted. The single change to the instrument is propagated to the connected objects 

highlighted in advance of the change. By highlighting as the property is selected the user is 

given visual feedback of exactly which objects will be impacted by the single property change. 

Now try another task. 

Create a Display Set. 

Bulk Data Editing with Engineering Data Editor 

Create a Report 

Compare Drawing Versions 

Streamline Engineering with Design Rules 

 

Create a Display Set 

An asset-centric solution, SmartPlant P&ID helps you present your data in the format that best meets the 
needs of your specific task, such as performing quality checks, issuing drawings for review, or creating 
construction packages. One function in SmartPlant P&ID that makes this possible is a display set, which 
basically queries the data and presents it in a graphical view. 
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Try the example below and see for yourself. 

1. Right-click in the P&ID, then click Apply Display Set on the shortcut menu. 
2. Right-click My Display Sets, then click Add Display Set. 
3. In the tree view, type the name QC1. 
4. Right-click QC1, then click Add Filter. 

 

5. In the Select Filter dialog box, select the My Folders folder, then click New. 
6. In the New Filter dialog box, select Simple Filter, then click OK. 
7. In the Add Filter dialog box, type the name Pipe Spec. 
8. Under Filter for, select Pipe Run. 
9. Under Edit, set the Property to Piping Material Class. Set the Operator to =. Leave 

the Value blank. 

 

10. Click OK. 
11. Click Tools > Options. On the Colors tab, set the background color to light grey. 

 

Modifying the background allows you to see all items filtered by the display set. 

12. In the Apply Display Set dialog box, set the default color for the Pipe Spec filter to red. 
13. On the Apply Display Set dialog box, click Apply. 

 

Any pipe run that does not have a piping specification associated with it is displayed in red. 

Next, find pipe runs that have a missing fluid code. 

1. In the QC1 filter, right-click Pipe Spec, then click Delete. 

2. Repeat steps 4 - 6. 
3. In the Add Filter dialog box, type the name Fluid Code. 
4. Under Filter for, select Pipe Run. 
5. Under Edit, set the Property to Fluid Code. Set the Operator to =. Leave the Value blank. 



6. Click OK. 
7. In the Apply Display Set dialog box, set the default color for the Fluid Code filter to blue. 
8. Click Apply. 

 

Any pipe run that does not have a fluid code associated with it is displayed in blue. 

Next, find pipe runs that have a construction status of new. 

1. In the QC1 filter, right-click Fluid Code, then click Delete. 

2. Repeat steps 4 - 6. 
3. In the Add Filter dialog box, type the name ConstrStatus. 
4. Under Filter for, select Pipe Run. 
5. Under Edit, set the Property to Construction Status. Set the Operator to =. Set 

the Value to New. 
6. Click OK. 
7. In the Apply Display Set dialog box, set the default color for the Construction Status filter to 

green. 
8. Click Apply. 

 

Any pipe run that has a construction status of new is displayed in green. 

Next, find pipe runs in which the design pressure is missing. 

1. In the QC1 filter, right-click ConstrStatus, then click Delete. 

2. Repeat steps 4 - 6. 
3. In the Add Filter dialog box, type the name Design Pressure. 
4. Under Filter for, select Pipe Run. 
5. Under Edit, set the Property to Design Max Press. Set the Operator to =. Leave 

the Value blank. 
6. Click OK. 
7. In the Apply Display Set dialog box, set the default color for the Design Pressure filter to purple. 
8. Click Apply. 

 

Any pipe run that does not have a design pressure associated with it is displayed in purple. 

Now try another task. 

Edit a System the "Smart" Way Using SmartPlant P&ID 

Bulk Data Editing with Engineering Data Editor 

Create a Report 

Compare Drawing Versions 

Streamline Engineering with Design Rules 
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Bulk Data Editing with Engineering Data Editor 

SmartPlant P&ID allows you to create and modify P&IDs in the graphic mode or in a tabular form. 
Engineering Data Editor is a tabular view that presents the plant data in a tabular format. It also provides 
filtering capabilities similar to a spreadsheet, allowing you to perform bulk editing of data using familiar 
commands such as copy and paste or by importing data from another spreadsheet. 

Try the example below and see for yourself. 

1. In Engineering Data Editor, select Edit View from the drop-down list. 

 

2. Select Pipe Run from the filter list. 
3. Select Design Max Pressure. 

 

 

All pipe runs are displayed. 

4. In the Design Max. Pressure column, type 40. 
5. Right-click on 40, then click Copy. 
6. Highlight the Design Max. Pressure column. 
7. Right-click the column, then click Paste. 

 

All instances are changed to 40. 

  AutoFilter 

8. On the toolbar, click View, then click AutoFilter. 



 

 

AutoFilter allows you to filter the items displayed in the Engineering Data Editor. When you 

click AutoFilter, arrows appear at the top of each column. 

9. Click the arrow at the top of the column that contains the data that you want to filter on and 
choose the value from the list that appears. 

 

For instance, if the Engineering Data Editor displays Pipe Component, but you want to see 

only gate valves, use the AutoFilter command to view the data. 

10. Click the arrow at the top of the Pipe Components Type column and choose gate valves. 

Now try another task. 

Edit a System the "Smart" Way Using SmartPlant P&ID 

Create a Display Set. 

Create a Report 

Compare Drawing Versions 

Streamline Engineering with Design Rules 

 

Create a Report 

SmartPlant P&ID provides easy to use report generation capabilities, allowing you to quickly create 
standard plant reports, such as equipment, line or valve lists, material takeoffs, and to do lists. Reports 
appear in familiar Microsoft Excel. Reports are easily customizable to meet your company standards. 

Try the example below and see for yourself. 

1. On the SmartPlant P&ID menu, click Reports > Plant Reports. 
2. In the Plant Reports dialog box, select Equipment List, then click OK. 
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The equipment list appears in Microsoft Excel. 

3. Repeat steps 1-2 for a line list and a valve list. 
4. In the P&ID, highlight a pipe run. 
5. Click Reports > Plant Reports. 
6. In the Plant Reports dialog box, select Pipe Run List, then click OK. 

7. In the Microsoft Excel report, change the following values: 

 Construction Status - Future 

 Diameter - 4" 

 Design Max. Pressure - 40.0 bar 
8. Click File > Save, then click File > Exit. 
9. In SmartPlant P&ID, click File > Import > Data File. 
10. In the File Import dialog box, select My Recent Documents, sort the documents by Date 

Modified (with most recent at the top) and find the Pipe Run List.xls that was just created. 

 

SmartPlant P&ID imports your changes. 

11. The symbology of the pipe run has changed to indicate its construction status is future. 

12.  

 

In the Properties dialog, view your other changes to the pipe run. 

Now try another task. 

Edit a System the "Smart" Way Using SmartPlant P&ID 

Create a Display Set. 

Bulk Data Editing with Engineering Data Editor 

Compare Drawing Versions 

Streamline Engineering with Design Rules 

 

Streamline Engineering with Design Rules 

SmartPlant P&ID’s built-in design rules and system editing capabilities also allow fast and consistent data 
entry throughout a complete piping system. The rules enable design validation across the project, and 
allow automatic updating of the design when the design basis changes. 

Rules are used in SmartPlant P&ID for the following reasons: 

 Placement rules ensure that the correct relationships are created when you place a new item or 
move an item in a drawing. 
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 Rules govern how properties are copied from one item to another in a relationship, and how 
properties are designated at placement. 

 Rules check consistency. 

 Implied items are defined in rules. 

Try the example below and see for yourself. 

1. In the Catalog Explorer tree view, expand the Piping > Routing > Process Lines node and 
select Primary piping. 

2. In the P&ID, route a process line in free space. Left mouse click, then move to another position, 
and then left mouse click again. Right mouse click to exit placement mode. 

 

 

 

3. In the Properties dialog, give the pipe run the following properties: 

 Fluid code - X 

 Insulation purpose - P 

 Nominal diameter - 3" 

 Design Max Press - 20.0 atm 
4. In the Catalog Explorer tree view, expand the Equipment Components > Nozzles node and 

select a nozzle to place. 
5. Place a nozzle on the vessel in the drawing. The nozzle will not allow placement in free space, it 

has to be connected to equipment, as can be seen with the ‘no place’ glyph (circle with slash 
line).  Select the nozzle in the Catalog Explorer by left clicking once. Hover with the nozzle over 
the line to show the Alignment Indicator. Move the cursor to the vessel, and left click to place on 
the vessel. 

 

Both the pipe run and the nozzle show data inconsistencies because the connect points are not 
attached. 



 

 

Rules provide visual indicators of data inconsistency. 

6. To connect the pipe run with the nozzle, select the top-most ‘black dot’ on the pipe run seen in 
the screenshot just before step 6. Once selecting the black dot with the mouse (left click the dot 
and hold mouse button down) move the dot up to the nozzle. Once the nozzle highlights the 
system is informing the user that a recognized relationship can be established between those two 
items and they can release the mouse button. 

 

7. Click the nozzle and view the properties, in the Properties window. 

The pipe run has copied some of its properties to the nozzle, but an inconsistency remains. 

8. Click the inconsistency flag, then right click and select Consistency Check. 

 



The insulation purpose that the nozzle inherited and the vessel do not match. 

 

9. Under Solutions, select the action you want to take. Notice that the system editing ‘scope’ 

changes according to which solution is selected.  Again, providing visual feedback to the user 
how ‘far’ the change will propagate, before the change is made.  Once the solution is 
decided Apply. 

 

Rules provide feedback for data discrepancy and a solution. 

Now try another task. 

Edit a System the "Smart" Way Using SmartPlant P&ID 

Create a Display Set. 

Bulk Data Editing with Engineering Data Editor 

Create a Report 

Compare Drawing Versions 

 

Compare Drawing Versions 

When more than one version of a drawing exists, SmartPlant P&ID allows you to view two versions side-
by-side and examine their differences. You can only compare a drawing only against a version of itself; 
that is, you cannot compare one drawing to a different drawing. 

Try the example below and see for yourself. 

1. Click Tools > Compare & Refresh. 
2. On the Compare With dialog box, select a database using the Available databases drop-down 

list box. 
3. In the History list box, select the drawing you want to compare your current drawing with. 
4. Click OK. 
5. On the Compare and Refresh dialog box, review the information in the Change 

groups and Change details areas. 
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Your current drawing displays on the right side of the screen. The version you are comparing it to 
displays on the left. 

6. In the Change groups area, click in the Action column. 
7. Using the drop-down list, select No Action or Refresh. 
8. Click OK to refresh the drawing and accept any changes or Cancel to dismiss the dialog box. 

 

SmartPlant P&ID keeps a record of all previous versions of a drawing. Using the History that is 
maintained, you can easily roll back to a previous version of a P&ID. 

1. In SmartPlant P&ID Drawing Manager, click Revisions > Version History. 
2. Select the version of the P&ID that you want to make current, then click Fetch. 

 

The P&ID is now the current version. Your later versions are maintained when you need to make 
them current. 

Now try another task. 

Edit a System the "Smart" Way Using SmartPlant P&ID 

Create a Display Set. 

Bulk Data Editing with Engineering Data Editor 

Create a Report 

Streamline Engineering with Design Rules 
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